foxynet's blog

t minus 1405 minutes and counting – again(2) – Apple Wireless Keyboard

by foxynet on October 16, 2007, no comments

So … the Apple store I ordered the Mac Mini from couriered … the wrong computer … back from their other store.

Groan.

At least I talked them into giving me a discount on a new Apple Wireless Keyboard. It doesn’t want to work with my Windows laptop, worked first time with a friend’s TiBook (10.3 even!) and first time with the iMac G5 at home.

With a bit of work it also works with Ubuntu Fiesty on my laptop:

Not 100% sure that this was required:

sudo apt-get install gnome-bluetooth

To get the MAC address of the keyboard:

sudo hidd --search

Substitute the MAC address returned from the search above for aa:bb:cc:dd:ee:ff in the following commands.

Edit /etc/bluetooth/hcid.conf and add the following section:

device aa:bb:cc:dd:ee:ff {
name "Apple Wireless Keyboard";
auth enable;
encrypt enable;
}

Enable Human Interface Devices:

sudo vim /etc/default/bluetooth

Look for the following line:

HIDD_ENABLED=0

Change it to:

HIDD_ENABLED=1

Restart the bluetooth daemon:

sudo /etc/init.d/bluetooth restart

Then connect to the keyboard!:

sudo hidd --connect aa:bb:cc:dd:ee:ff

It should prompt you to type in a pairing pin number on your bluetooth keyboard and on your existing keyboard.

I had all sorts of trouble actually getting the pairing to work … in the end a reboot sorted things out, I suspect because the reboot autodetected and loaded the correct modules.

References:

https://help.ubuntu.com/community/BluetoothSetup

http://ubuntuforums.org/showthread.php?t=224673

http://ubuntuforums.org/showthread.php?p=3523271

Happy days!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>